Opencart 3.0.0 - Uyarı: API erişim iznine sahip değilsiniz!

point

Üye
26 Ocak 2018
6
1
37
Herkese merhabalar,

Opencart 3.0.0 kurulu. Siparişleri silmeye veya düzenlemeye çalışınca Uyarı: API erişim iznine sahip değilsiniz! uyarısı almaktayım.

Kullanıcılar > API alanından api ayarlarını yaptım.
Mağaza > seçenekler alanından gerekli yerleri seçtim.

Ama yinede çözüm olmadı.

Yardımlarınıza ihtiyacım var. İyi çalışmalar
 
Admin

Admin

yilmaz70
Yönetici
13 Mar 2017
204
46
İstanbul
Merhaba,

Opencart 3.0.0 yerine 3.0.2.0 sürümünü kurmanızı tavsiye ederim. Daha stabil bir sürümdür.
Bazı tema ve eklentiler ile uyumsuzluk dışında iyi çalışıyor. Sadece cache problemi yaşanabiliyor 3 sürümünde.

İsterseniz önce şu an kullandığınız sürümde cache temizliği yaparak deneyin. Olmaz ise daha sonra yeni api tanımlaması yapın.
Çözüm olursa dahi 3.0.2.0 sürümünü kurmanızı tekrar tavsiye etmek durumundayım.

Kolay gelsin.
 

point

Üye
26 Ocak 2018
6
1
37
Malesef ki çözüm olmadı. Anlamadığım bir nokta ise aynı siteyi farklı bir hostinge taşıyorum orada çalışıyor. Ama mevcut hostingde çalışmıyor. Taşıdığım yer de en berbat diyebileceğim yerlerden biri. Anlamadım gitti :)
 
muhammetali

muhammetali

Administrator
Yönetici
14 Mar 2017
79
42
Karaman
Panelden "mod security" kapatmayı dener misin?

panelden yapamazsan .htaccess dosyasına şu kodları ekleyerek dene.

Kod:
<IfModule mod_security.c> SecFilterEngine Off SecFilterScanPOST Off
</IfModule>

Hata kayıtlarındaki hataları buraya yazarmısın?
 
Son düzenleme:
  • Like
Tepkiler: point

point

Üye
26 Ocak 2018
6
1
37
Şuanda ekledim yine aynı hatayı verdi. Herhangi bir hata kaydı bulunmuyor. Ek olarak panelden de kapatıp denedim yine olmadı.


Panelden "mod security" kapatmayı dener misin?

panelden yapamazsan .htaccess dosyasına şu kodları ekleyerek dene.

Kod:
<IfModule mod_security.c> SecFilterEngine Off SecFilterScanPOST Off
</IfModule>

Hata kayıtlarındaki hataları buraya yazarmısın?