Ürün Sayfası 500 hatası veriyor.

'Opencart 2.3.0.2 Karşılaşılan Hatalar' forumunda Zaren tarafından 30 Mart 2017 tarihinde açılan konu

  1. Zaren

    Zaren Yeni Üye

    Katılım:
    22 Mart 2017
    Mesaj:
    28
    Ödül Puanları:
    3
    http://prntscr.com/eqa7n8
    ekran görüntüsünde görüldüğü gibi bir hatayı ilk kez gördüm. Tecrübesi olan var mı?
     
  2. Admin

    Admin yilmaz70 Site Yetkilisi

    Katılım:
    13 Mart 2017
    Mesaj:
    183
    Ödül Puanları:
    28
    Cinsiyet:
    Erkek
    Bu hata ile karşılaşmadan önce sitenizde en son ne işlem yapıldı?
     
  3. Zaren

    Zaren Yeni Üye

    Katılım:
    22 Mart 2017
    Mesaj:
    28
    Ödül Puanları:
    3
    Herhangi bir işlem yapılmadı bildiğim kadarı ile. En fazla excel eklentisi yuklenmiştir. ama ondan sonra çalışıyordu. sadece ürün sayfası çalışmıyor diğer sayfalar çalışıyor. Loglardaki hata mesajı şu şekilde
    "Class 'Controllercatalogproduct' not found in /****/*****/public_html/vqmod/vqcache/vq2-system_modification_system_engine_action.php on line"
     
  4. Admin

    Admin yilmaz70 Site Yetkilisi

    Katılım:
    13 Mart 2017
    Mesaj:
    183
    Ödül Puanları:
    28
    Cinsiyet:
    Erkek
    Anladığım kadarı ile vqmod ile yüklemişsiniz eklentiyi.

    Öncelikle, 2.3 sürümünün kurulumunu nasıl yaptınız, hosting cpanel üzerinden mi?
    Vendor ve composer dosyalarını yükledinizmi?
     
  5. Zaren

    Zaren Yeni Üye

    Katılım:
    22 Mart 2017
    Mesaj:
    28
    Ödül Puanları:
    3
    direk ftp ile attım dosayları sonra arayüzden kendim kurdum
     
  6. Zaren

    Zaren Yeni Üye

    Katılım:
    22 Mart 2017
    Mesaj:
    28
    Ödül Puanları:
    3
    vendor ve composer hangi klasorde
    bu isimde klasor yok bende
     
  7. Admin

    Admin yilmaz70 Site Yetkilisi

    Katılım:
    13 Mart 2017
    Mesaj:
    183
    Ödül Puanları:
    28
    Cinsiyet:
    Erkek
    2.3 sürüm kurulum dosyaları içerisinde yer alır.

    Hangi dil kurulum yaptınız ona göre yönlendireyim sizi.
     
  8. Zaren

    Zaren Yeni Üye

    Katılım:
    22 Mart 2017
    Mesaj:
    28
    Ödül Puanları:
    3
    bu hatayı aldığım syafada türkçe e-piksel çevirisi olan sürümü kurulu
     
  9. Admin

    Admin yilmaz70 Site Yetkilisi

    Katılım:
    13 Mart 2017
    Mesaj:
    183
    Ödül Puanları:
    28
    Cinsiyet:
    Erkek
  10. Zaren

    Zaren Yeni Üye

    Katılım:
    22 Mart 2017
    Mesaj:
    28
    Ödül Puanları:
    3
    İnceleyim bakalım sonucu paylaşırım sizinle
     
  11. Zaren

    Zaren Yeni Üye

    Katılım:
    22 Mart 2017
    Mesaj:
    28
    Ödül Puanları:
    3
    üstad dediğiniz gibi dosyaları yükledim. Değişen bir sey olmadı
    log kayıtları şu şeklide
    "
    [30-Mar-2017 17:31:30 Europe/Moscow] PHP Fatal error: Class 'Controllercatalogproduct' not found in /******/public_html/vqmod/vqcache/vq2-system_engine_action.php on line 43
    [30-Mar-2017 17:35:00 Europe/Moscow] PHP Fatal error: Class 'Controllercatalogproduct' not found in /*******/public_html/vqmod/vqcache/vq2-system_storage_modification_system_engine_action.php on line 43
     
  12. Admin

    Admin yilmaz70 Site Yetkilisi

    Katılım:
    13 Mart 2017
    Mesaj:
    183
    Ödül Puanları:
    28
    Cinsiyet:
    Erkek
    Opencart 2.x sürümleri için vqmod genellikle sorun çıkarır.
    Zaten ocmod eklenti vqmod alternatifi olarak yeni sürümlerde aktif hale getirilmiştir.

    Bunun için; Opencart 2 sürümleri için vqmod eklentisi ocmod olarak kurulumu yapılması gerekebiliyor.

    Bu ocmod eklentisi, vqmod ile kurulan modüllerde hata olasılığını en aza indirgemeye yarıyor.

    Bu eklentiyi yüklemeden önce, kurmuş olduğunuz excell eklentisini pasif edin ve modifikasyonlara gidip refresh yapmayı unutmayın.

    Daha sonra linkte mevcut olan eklentiyi kurun ve modifikasyonlar bölümünde tekrar refresh yapın.

    Bu işlemleri sırası ile yaparsak verimli bir sonuç elde ederiz.

    Mutlaka problem için bir çözüm bulunacaktır ama adım adım gitmek zorundayız:)

     
  13. Zaren

    Zaren Yeni Üye

    Katılım:
    22 Mart 2017
    Mesaj:
    28
    Ödül Puanları:
    3
    Adım adım gitmek te haklısın;
    eski vqmod kurulum klasorunu tamamen sileyim mi ne dersin yoksa ustune mi yazsın
     
  14. Admin

    Admin yilmaz70 Site Yetkilisi

    Katılım:
    13 Mart 2017
    Mesaj:
    183
    Ödül Puanları:
    28
    Cinsiyet:
    Erkek
    Bahsedilen eklenti, vqmod kurulumunda sağlam bir zemin olması için geliştirilmiş.

    Vqmod kurulum öncesi yedeğiniz var ise, vqmod tamamen silmekte fayda var.
    Eklenti kurulur, daha sonra vqmod eklenir ise daha sağlıklı olacaktır.

    Ama yedeğiniz yok ise, ürünleriniz fazla ise, riske girmek istemiyorsanız sadece vqmod pasifize edin.

    Olmadı, tamamen yedek alın önce, daha sonra vqmod kaldırın. Baktınız hata veriyor, o zaman yedeği geri yüklersiniz.
     
  15. Zaren

    Zaren Yeni Üye

    Katılım:
    22 Mart 2017
    Mesaj:
    28
    Ödül Puanları:
    3
    Site zaten yapım aşamasında adım adım tüm yedekleri mevcut. Ama sanırım yeniden kurmamız gerekecek denedim dediklerinizi aynı hata ve aynı log kayıtları yine geliyor

    aklınıza gelen başka bir şey varsa deneyeyim yoksa yeni baştan kurmayı düşünüyorum, eğer denenecek bir yol varsa onu da test etmiş olayım
     
  16. Admin

    Admin yilmaz70 Site Yetkilisi

    Katılım:
    13 Mart 2017
    Mesaj:
    183
    Ödül Puanları:
    28
    Cinsiyet:
    Erkek
    Yapım aşamasında ise hiç gereksiz yere uğraşmayın o zaman.
    Bir de, neden 2.3 sürümü istiyorsunuz?
    İleride özel bir modül ihtiyacı olacak mı, ona göre bir sürüm kurun derim.
     
  17. Zaren

    Zaren Yeni Üye

    Katılım:
    22 Mart 2017
    Mesaj:
    28
    Ödül Puanları:
    3
    Son sürüm olduğu için onun dışında bir gerekçe yok açıkcası son sürüm daha güvenlidir diye düşündüm sizin tavsiyeniz nedir?
     
  18. Admin

    Admin yilmaz70 Site Yetkilisi

    Katılım:
    13 Mart 2017
    Mesaj:
    183
    Ödül Puanları:
    28
    Cinsiyet:
    Erkek
    Güvenlik açısından Opencart yazılımı sürümlere göre bir farklılık göstermez.

    Son sürümün dezavantajı, sürüme uygun her modülün tedarik edilemeyişi.
    Bir de seo url konusunda daha farklı bir yapıya sahip.
    Default tema açısından belki bir sıkıntı çıkarmıyor gibi görünebiliyor, ancak özel tema eklendiğinde uyumsuzluk ortaya çıkabiliyor.

    Ben hemen hemen tüm sitelerimde hala 2.0.3.1 sürümü kullanıyorum mesela.

    Tercih sizin:)

    Daha önce dediğimiz gibi, adım adım gidilirse daha sağlıklı bir proje ortaya çıkar.
     
  19. Zaren

    Zaren Yeni Üye

    Katılım:
    22 Mart 2017
    Mesaj:
    28
    Ödül Puanları:
    3
    bende şimdiye kadar hep 2.3.x sürümü kullandım bu şekilde problem yaşamamıştım açıkcası.
    bütün sayfalar çalışıyor sadece ütün ekleme sayfası çalışmıyor çok ilginç oldu.
    acaba database den tüm ürünleri silsem bir faydası olur mu diyeceğim ama hata kodu vqmod satır 43 diyor oraya bakıyorum regitery dışında birşey yazmıyor
     
  20. Admin

    Admin yilmaz70 Site Yetkilisi

    Katılım:
    13 Mart 2017
    Mesaj:
    183
    Ödül Puanları:
    28
    Cinsiyet:
    Erkek
    Burada bir şey paylaşılmış, ama inceleyemedim daha.

    Bahsedilen hata ile daha önce karşılaşmadığım için hemen yorumda bulunmam doğru olmaz.

    Vaktiniz var ise inceleyip dönüş yapalım?